0328 | ตั้งค่า Mikrotik ให้ใช้งาน DNS Over HTTPS (DoH)

RouterOS 6.47 นั้นได้รองรับการใช้งาน DNS Over HTTPS แล้ว ซึ่งเดิมจะใช้งานผ่าน Protocol UDP ใน Port 53 ซึ่งข้อมูลนั้นไม่ได้มีการเข้ารหัส ซึ่งอาจทำให้ผู้ให้บริการอินเตอร์เน็ตสามารถดูการ dns query ว่าเราเข้าเว็บไซต์อะไรบ้าง

สำหรับวิธีการตั้งค่า Mikrotik ให้ใช้งาน DNS Over HTTPS ได้นั้น สามารถทำตามขั้นตอนต่อไปนี้ได้เลยครับ

1. อัพเดต RouterOS ให้มีเวอร์ชั่น 6.47 เป็นต้นไป
2. ดาวน์โหลด และ Import root certificates

/tool fetch url=https://curl.haxx.se/ca/cacert.pem
/certificate import file-name=cacert.pem passphrase=""

3. เพิ่ม DNS เข้าใป

/ip dns set use-doh-server=https://1.1.1.1/dns-query verify-doh-cert=yes

4. ลบ DNS เดิมออก

/ip dns set servers=""

เพียงเท่านี้ก็เป็นอันเสร็จครับ โดยในข้อ 3 และ 4 จะทำผ่าน Winbox ก็ได้ครับ โดยตั้งค่าตามภาพ


 

และลองไปตรวจสอบว่าตั้งค่าถูกต้องแล้วหรือไม่ ให้ไปดูที่ Connections ใน Firewall ครับ จะเห็นว่า มีการติดต่อไปที่ IP 1.1.1.1 บน port 443 ครับ

เพิ่มเติม หากต้องการใช้ DNS ของ Google สามารถเปลี่ยน URL มาเป็น https://8.8.8.8/dns-query ได้ครับ
หรือพิมพ์

/ip dns set use-doh-server=https://8.8.8.8/dns-query verify-doh-cert=yes

ซึ่งจากการ ping ดู DNS ของ Cloudflare ได้ค่าที่ต่ำกว่า ผมเลยเลือกใช้ของ Cloudflare ครับ

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.