0069 | แก้ปัญหา os ใน Vmware บน windows 7 เล่นเน็ตไม่ได้

คนที่ใช้ windows 7 อยู่ และได้ติดตั้ง vmware เอาไว้ คงเจอปัญหาแบบเดียวกันคือ os ที่ได้ติดตั้งไว้ใน vmware มันไม่สามารถเข้าเว็บไซต์อะไรได้เลย? วันนี้ผมมีวิธีแก้แบบง่ายๆมาฝากครับ

1.

1

ไปเปลี่ยนการเชื่อมต่อใน vmware ให้เป็นแบบ Host-only ซะก่อน (แบบอื่นไม่แน่ใจว่าจะได้หรือเปล่า ยังไม่ได้ทดลองครับ)

2.

2

หลังจากนั้นก็ start vmware แล้วเข้าไปดูว่า os ที่อยู่ใน vmware ของเราได้รับเป็น ip อะไร (ของเดิมจะตั้งให้รับจาก DHCP) แล้วก็จำ ip ไว้นิดนึง

3.

3

หลังจากนั้น กลับมาที่ windows 7 ของเรา? ให้ไปที่ Network Connection ของเรา จะสังเกตุเห็นว่า มี Adapter เพิ่มมา 2 อัน ก่อนที่เราจะติดตั้ง vmware? ซึ่งที่ผมทำ Highlight เอาไว้ด้วยสีเหลือง จะมีคำว่า? VMware virtual Ethernet Adapter อยู่ ให้ลองเช็คดูว่า ip ของอันไหนที่ตรงกับ ip ที่อยู่ใน vmware ของเราที่ให้ดูเมื่อขั้นตอนที่ 2

4.

4

เจอแล้ว อันที่เหมือน 🙂

5.

5

หลังจากนั้น ไปที่ Adapter ที่เป็นของจริง คลิกขวา เลือก? properties แล้วเลือกที่ tab Sharing? แล้วติ๊กเครื่องหมายถูกที่ผมวงเอาไว้ แล้วเลือก Adapter ให้ตรงกับอันในขั้นตอนก่อนหน้าด้วยครับ? ของผมจะชื่อ Local Area connection 2 แล้วก็คลิก ok ครับ

6.

6

เมื่อคลิก ok มันจะมีข้อความเตือน ว่ามันจะเปลี่ยน ip ให้เป็น 192.168.137.1 อันนี้เพราะอะไร ก็ไม่ทราบเหมือนกัน ก็กด Yes ไป

7.

7

คราวนี้ก็จะสังเกตุเห็นคำว่า Shared ขึ้นมา? ก่อนหน้านี้จะไม่มีครับ

8.

8

แล้วกลับเข้าไปใน vmware อีกที คราวนี้ไป fix ip ให้อยู่ในชุดเดียวกับ 191.168.137.x? และ Defaul gateway และ DNS ให้ใส่เป็น 192.168,137.1 ลงไป หรือดูจากในรูปก็ได้ครับ ตั้งตามนั้นได้เลย

9.

9

เย้ๆๆๆ เล่นเน็ตได้แล้ว 🙂

แค่นี้แหละครับ เสร็จแล้ว? ง่ายไหมละ ก่อนหน้านี้ ไปเปิดของเว็บอื่นดู ให้ทำอะไรก็ไม่รู้เยอะไปหมด จนมึน ทำตามผม รับรองว่าเล่นเน็ตได้ 100%

6 thoughts on “0069 | แก้ปัญหา os ใน Vmware บน windows 7 เล่นเน็ตไม่ได้

  1. Freedomlover

    เอาแบบง่ายๆ ลองตั้งเป็น bridge ดูครับ ให้มันรับ ip จากเร้าเตอร์ไปเลย

  2. Jay Duanjaem

    พอเลือกเป็น Host-only แล้ว ใน VMware ให้ไป Auto IP ใหม่ก่อนอีกรอบหนึ่งครับ

Leave a Reply

Your email address will not be published. Required fields are marked *